愛查股網 www.411764.live 股票查詢最好股票網 個股數據查詢好股網 關閉本站廣告
愛查股網
股票查詢最好股票網 個股數據查詢好股網
您的位置:愛查股網 > 股票公式 > 大智慧公式
股票公式搜索:

大智慧開天眼主圖指標公式

2020/2/17 16:36:49

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
DKX:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
妖:DKX*1.1,Color000080,LINETHICK2,PRECIS2,LAYER2;
{黃色塊及坑后上漲;K線低位黃金坑。
該組源碼的作用是:在大盤股指的時間周期末端,波段拉升前的挖坑洗盤重要標志。
該標志,僅僅作為分辨右側交易前,研判大牛股啟動的左側黃色K線坑的建倉洗盤。并非左側買進信號!}
TYP := (HIGH + LOW + CLOSE)/3;
CCI := (TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
M1P:=30;
P2P:=100;
VAR1P:=(C+H+O+L)/4;
洗盤P:=MA(VAR1P,M1P)*(1-P2P/1000);
STICKLINE(CCI<=-100,L*0.995,L*0.995,9.5,0),COLORRED,LINETHICK6;
STICKLINE(CCI<=100 AND L<=洗盤P,L*0.99,L*0.99,9.5,0),colorYellow,LINETHICK6;
{CF}
CF:=(C-REF(C,1))/(REF(C,1))*100;
STICKLINE(H=C AND O<>C,O,O+(H-O)/3,6.5,0),COLORYELLOW,LAYER0;
STICKLINE(CF>1.0935 AND H=C,O+(H-O)/3,O+(H-O)/3*2,6.5,0),COLORYELLOW{COLORMAGENTA},LAYER0;
STICKLINE(CF>1.0935 AND H=C AND O<>C,O+(H-O)/3*2,C,6.5,0),COLORYELLOW,LAYER0;
K2:=1;
M55:=MA(C,3);
A3:=IF(K2<>2,EMA((EMA(C,5)+EMA(C,6)+EMA( C,7))/3,3),0);
黃金跑道:IF(M55>REF(A3,1),A3,0),PRECIS2,colorYellow,LINETHICK0;{黃金跑道線}
{突破捉妖。拉升信號}
{三軌主圖}
MC:=100;
中軌:MA(CLOSE,100),colorGray,PRECIS2,LINETHICK2,LAYER2;
NN:=0.7; {0.4}
MIDZ:=MA(CLOSE,MC);{中軌}
UPPER:=MIDZ+NN*STD(CLOSE,MC);{上軌}
LOWER:=MIDZ-NN*STD(CLOSE,MC);{下軌}
{2、中期下插線}
BN1:=MA(CLOSE,13)+MA(CLOSE,13)-REF(MA(CLOSE,13),1); {34}
分水嶺N1:=IF(MA(CLOSE,100)Y1:=分水嶺N1-(EMA(C,2)-分水嶺N1);
OUT6:=CROSS(LOWER,Y1);
DRAWTEXT(OUT6,O*1,'↖突破'),COLORWHITE;
{開天眼--只適合做K線向上爬坡,波段初起時的股票,當趨勢結束會消失。
出信號后--不要在糾結過往的大牛股為什么沒信號,那是因為前一波段已經結束! }
F2:=BARSLAST(EMA(C,3)<=EMA(C,5));{3、13}
F3:=IF(EMA(C,3)>=EMA(C,3),EMA(C,5),0); {3、13、5;3、3、30}
天眼:IF(CURRBARSCOUNTBR:=MA(CLOSE,8)+MA(CLOSE,8)-REF(MA(CLOSE,8),1);{原13}
分水嶺R:=IF(MA(CLOSE,13)YR:=分水嶺R-(EMA(C,3)-分水嶺R);
{XGC:=IF(YR>AN3,YR,0);}
{F5上穿YR開天眼}
OUTF:=CROSS(天眼,YR);
DRAWTEXT(OUTF,L*1,'★天眼'),COLORRED;
{★追財神--原則上K線變紅時才追}
VAR16:=MA(CLOSE,30);
上軌16:=VAR16+2*STD(CLOSE,60);
XG16:=CROSS(C,上軌16);
DRAWTEXT(XG16 AND (C1.0935 AND H=C AND O<>C)),H*1.02,'★追財神'),COLORYELLOW;
{紅綠導航}
{紅綠三角【副圖】}
A10304:=REF(HIGH,3)=HHV(HIGH,2*3+1);
B10304:=FILTER(A10304,3);
C10304:=BACKSET(B10304,3+1);
D10304:=FILTER(C10304,3);{高點}
A20304:=REF(LOW,3)=LLV(LOW,2*3+1);
B20304:=FILTER(A20304,3);
C20304:=BACKSET(B20304,3+1);
D20304:=FILTER(C20304,3);{低點}
E10304:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E20304:=(HIGH+LOW)/2;{高低點出現在同一K線上時可作取舍}
H10304:=(D10304 AND NOT(D20304 AND E10304>=E20304)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
L10304:=(D20304 AND NOT(D10304 AND E10304=E20304));
X10304:=REF(BARSLAST(H10304),1)+1;
F10304:=BACKSET(H10304 AND COUNT(L10304,X10304)>0,LLVBARS(IF(L10304,LOW,10000),X10304));
G10304:=F10304>REF(F10304,1);
I10304:=BACKSET(G10304,2);
LD0304:=I10304>REF(I10304,1);{過濾后低點}
L20304:=LD0304 OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X20304:=REF(BARSLAST(L20304),1)+1;
F20304:=BACKSET(L20304 AND COUNT(H10304,X20304)>0,HHVBARS(IF(H10304,HIGH,0),X20304));
G20304:=F20304>REF(F20304,1);
I20304:=BACKSET(G20304,2);
HD0304:=I20304>REF(I20304,1);{過濾后高點}
UU0304:=BACKSET(BARSTATUS=2,BARSLAST(LD0304)+1);
VV0304:=UU0304>REF(UU0304,1);
UU20304:=BACKSET(BARSTATUS=2,BARSLAST(HD0304)+1);
VV20304:=UU20304>REF(UU20304,1);
{以下語句為三角形部分}
底:REF(L,BARSLAST(VV0304)),COLORMAGENTA,LINETHICK2,PRECIS2,LAYER2;
頂:REF(H,BARSLAST(VV20304)),COLORGreen,LINETHICK2,PRECIS2;
{文字}
NN304:= DISPSTATUS=2;
DRAWTEXT(nn304,底,'' +NUMTOSTRN(底,2)+''),COLORMAGENTA,LINETHICK1;
DRAWTEXT(nn304,頂,''+NUMTOSTRN(頂,2)+''),COLORGreen,LINETHICK1;
A0X顯:=(L+H+C*2)/4;
工作:=EMA(A0X顯,14);
A1X:=(工作-REF(工作,1))/REF(工作,1)*100;
真妖:IF(H>=REF(A0X顯,BARSLAST(CROSS(A1X,0)))*1.3,
REF(A0X顯,BARSLAST(CROSS(A1X,0)))*1.3,0),PRECIS2,LINETHICK0,Color0080FF;
STICKLINE(H>=REF(A0X顯,BARSLAST(CROSS(A1X,0)))*1.3,
REF(A0X顯,BARSLAST(CROSS(A1X,0)))*1.3,
REF(A0X顯,BARSLAST(CROSS(A1X,0)))*1.3,15, 0),Color0080FF,LINETHICK2;
{下跌三角形:綠色三角形畫完介入}
StickLine(VV0304,頂,底,0,0),ColorD56A00,linethick2,LAYER2;
DRAWLINE(VV20304,H,VV0304,L,0),ColorD56A00,linethick2,LAYER2;{斜}
DRAWLINE(VV20304,H,VV0304,頂,0),ColorD56A00,linethick2,LAYER2;
{上漲三角形:紅色三角形畫完出局}
StickLine(VV20304 ,頂,底,0,0),COLORred,linethick2,LAYER2;
DRAWLINE(VV0304,L,VV20304,H,0),COLORred,linethick2,LAYER2;{斜}
DRAWLINE(VV0304,L,VV20304,底,0),COLORred,linethick2,LAYER2;
{壓力斜線}
DRAWLINE(H>=HHV(H,20),H,L<=LLV(L,8),HHV(H,8),1),COLORWHITE,LINETHICK1,dotline,LAYER1;
{黃金跑道線}
PARTLINE(A3,M55>REF(A3,1)),PRECIS2,colorYellow,LINETHICK1,LAYER0;
{開天眼}
PARTLINE(F3,CURRBARSCOUNTSTICKLINE(C>O OR (C=O AND C>REF(C,1)),H,L,0,0),COLOR5454FF;
STICKLINE(C>O OR (C=O AND C>REF(C,1)),C,O,7.5,0),COLOR000000;
STICKLINE(C>O OR (C=O AND C>REF(C,1)),C,O,7.5,1),COLOR5454FF,LAYER1;
STICKLINE(CSTICKLINE(CSTICKLINE(CRS_VA:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
KA:=SMA(RS_VA,5,1);
DA:=SMA(KA,5,1);
JA:=3*KA-2*DA;
X:=REF(JA,1)<10 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
X0:=REF(JA,1)>99 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
K0:=REF(KA,1)>83 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
{K1:=REF(KA,1)<11 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);}
STICKLINE(X,L,L,20,0),COLOR008888,LAYER0;{超跌}
STICKLINE(X,C,O,4.5,0),COLORFF00FF,LAYER0;{粉色底部}
STICKLINE(X0,O,C,4,0),COLORWHITE,LAYER0;{白色翻轉}
STICKLINE(K0,O,C,4,0),COLOR1880FF,LAYER0;{橘色加速}
DRAWTEXTABS(15,10,'■所屬板塊:'+BKNAME),Color66cccc,linethick2;
流通盤大小:=FINANCE2(37)/1000000*100;
DRAWTEXTABS(25,30,'流通盤大?。?+NUMTOSTRN(流通盤大小,2)+'億'),LINETHICK1,Color66cccc;
每股收益:=FINANCE2(3);
每股市盈率:=DYNAINFO(39);
銷售毛利率:=FINANCE2(12);
主營收入同比:=FINANCE2(11);
凈利潤同比增長:=FINANCE2(10);
DRAWTEXTABS(185,30,'收益:'+NUMTOSTRN(每股收益,2)+'元'),LINETHICK1,COLOR66cccc;
DRAWTEXTABS(350,50,'市盈率:'+NUMTOSTRN(每股市盈率,1)+'倍'),LINETHICK1,COLOR66cccc;
DRAWTEXTABS(350,30,'銷售毛利率:'+NUMTOSTRN(銷售毛利率,2)+'%'),LINETHICK1,COLOR66cccc;
DRAWTEXTABS(185,50,'主營入同比增長:'+NUMTOSTRN(主營收入同比,2)+'%'),LINETHICK1,Color66cccc;
DRAWTEXTABS(25,50,'凈利潤同比增長:'+NUMTOSTRN(凈利潤同比增長,2)+'%'),LINETHICK1,COLOR66cccc;
DRAWTEXTABS(20,70,'【復盤】:'+SELFSTRING('復盤')+''),LINETHICK2,Colorwhite;
DRAWTEXTABS(20,90,'【題材】:'+SELFSTRING('題材')+''),LINETHICK2,Color66cccc;
DRAWTEXTABS(26,112,'■解禁: '+SelfString('解禁')),LINETHICK2,COLORYELLOW;
DRAWGBK(c>0,STRIP(RGB(0,110,0),RGB(0,0,0),1)),LAYER0;

大智慧開天眼主圖指標公式的選股公式

股票公式推薦
在線查股
商務合作:在線客服
愛查股網不推薦股票,不收會員,網站內的廣告不代表本股票網的觀點,由此引起的一切法律責任均與本站無關,股市有風險,投資需謹慎。粵ICP備17111814號-1
特別提示:本站不為所提供數據的錯誤、殘缺、延遲或因依靠此信息所采取的任何行為負責。本股票網提供的所有內容僅供參考,不構成投資建議,投資者據此操作,風險自擔。
在酒店工作赚钱吗 青海快三预测网 吉林快三工具走势图 18luck线上娱乐百家乐 好股票推荐金股领取 河南快三的开奖结果今天 北京快乐8是正规彩票吗 广东11选5定位走势图 吉林11选五快方法选二号 中国配资网 河北快三开奖结果今天推荐